Scheduled Upgrade to PHP 5.6 All the latest from MaxterHost


With the PHP 5.5 branch reaching the end of its support time-frame, we will be upgrading all servers that are still running PHP 5.5 as the native version to PHP 5.6.

The upgrade to PHP 5.6 is scheduled to take place on 02 September 2016.

Most improvements in PHP 5.6 have no impact on existing code. There are a few incompatibilities and new features that should be considered, but overall the upgrade to PHP 5.6 should be seamless for almost all websites.

What effects could the upgrade have on your website and scripts?

If you have a rather old website and your scripts aren’t up-to-date, this might cause compatibility issues, where PHP errors and warnings would occur. These errors are normally logged in the file "error_log" inside the "public_html" folder and its sub-folders.

How should you prepare for the upgrade?

You should make sure that all your scripts are upgraded to the latest version available and are compatible with PHP 5.6. Not only is this required to assure compatibility with the latest PHP standards, but it’s also very important and essential in order to protect your website from any possible security vulnerabilities.

Many popular scripts (WordPress, Joomla, Magento, etc.) can be easily updated using Softaculous, our free script auto-installer, which you can find inside cPanel under the Software/Services group. To import an existing installation, please follow the import guide and then run the upgrade by following the upgrade guide.

If you're a developer or have a custom website programmed in PHP, there's an official guide for migrating from PHP 5.5. to PHP 5.6.

How you can keep using an older, unsupported PHP version

For all clients who aren't prepared for the upgrade to PHP 5.6 yet, we offer the possibility to enable an older PHP version for your account, with the help of CloudLinux HardenedPHP. If you still require PHP 5.5 until you upgrade your scripts/website, you can enable it under cPanel » Select PHP Version.

However, please note that it's highly recommended to use the latest supported version of PHP for security and performance reasons. An older PHP version should only be enabled temporary, during the transitional phase while you upgrade your scripts/website.

Should you have any questions or concerns in regards to this upgrade, please don’t hesitate to let us know.


  Print


Comments


  Add Comment

Confirm Submission

Please enter the text from the image in the box provided, this helps us to prevent spam.



Powered by WHMCompleteSolution