Scheduled Upgrade to PHP 7.1 All the latest from MaxterHost


With the PHP 5.6 and PHP 7.0 branches reaching their end of support time-frame, we will be upgrading all servers and accounts that are still running PHP 5.x and/or PHP 7.0 to PHP 7.1.

The upgrade to PHP 7.1 as the system default version is scheduled to take place on 17 November 2018. All accounts that are still running PHP 5.x or PHP 7.0 will be switched to PHP 7.1.

This upgrade is expected to improve the overall performance of our servers and the hosted websites, as PHP 7 is known to have significantly better performance than PHP 5.

The upgrade from PHP 5.6 to PHP 7 is a major upgrade. There are a few incompatibilities and new features that you or your developers should take into consideration.

As a rule of thumb, your website/account should be compatible with PHP 7.1 if all your scripts (e.g. WordPress, Joomla, etc.) are up-to-date. Updates should be applied at least once per month. If you haven't updated your scripts since a long time, we strongly advise you to update soonest possible to assure full compatibility and cover security vulnerabilities. If you use WordPress, you can check the compatibility of your plugins/themes with the PHP Compatibility Checker plugin.

Why is this PHP upgrade necessary?

As PHP 5.6 and 7.0 will soon officially reach their end of support, these versions will no longer receive any bug fixes or security updates. All security vulnerabilities that will be discovered and exploited after the end of support date will no longer be patched, which would represent a risk for our server and your websites. For this reason, PHP 5.6 and 7.0 should no longer be used starting December 2018.

What effects could the upgrade have on your website and scripts?

If you have a rather old website and your scripts aren’t up-to-date, this might cause compatibility issues, where PHP errors and warnings would occur. This can lead to "500 Internal Server Error" or to limited functionality of the website. These errors are normally logged in the file "error_log" inside the "public_html" folder and inside the sub-folders.

Please check the "error_log" files under your account before contacting us for support. You should note that we cannot assist with issues related to third party scripts, as it is out of the scope of our support, but in some cases we can try to help on a best-effort basis, as a gesture of goodwill.

How should you prepare for the upgrade?

You should make sure that all your scripts are upgraded to the latest version available and are compatible with PHP 7.1. Not only is this required to assure compatibility with the latest PHP standards, but it’s also very important and essential in order to protect your website from any possible security vulnerabilities.

Many popular scripts (WordPress, Joomla, Magento, etc.) can be easily updated using Softaculous, our free script auto-installer, which you can find inside cPanel under the Software group. To import an existing installation, please follow the import guide and then run the upgrade by following the upgrade guide.

If you're a developer or have a custom website programmed in PHP, there's an official guide for migrating from PHP 5.6 to PHP 7.0 and from PHP 7.0 to 7.1.

How you can keep using an older, unsupported PHP version

For all clients who aren't prepared for the upgrade to PHP 7.1 yet, we offer the possibility to enable an older PHP version for your account, with the help of CloudLinux HardenedPHP. If you still require PHP 5.x until you upgrade your scripts/website, you can switch back to older PHP versions under cPanel » Select PHP Version.

However, please note that it's highly recommended to use the latest supported version of PHP for security and performance reasons. An older PHP version should only be enabled temporary, during the transitional phase until you upgrade your scripts/website.

Should you have any questions or concerns regarding this upgrade, please don’t hesitate to let us know.


  Print


Comments


  Add Comment

Confirm Submission

Please enter the text from the image in the box provided, this helps us to prevent spam.



Powered by WHMCompleteSolution