Installation of LiteSpeed Cache for WordPress All the latest from MaxterHost


As part of our on-going efforts to mitigate recent performance and stability issues, caused by CloudLinux and some resource-intensive accounts, we have been advised and decided to enable LiteSpeed Cache for all hosted WordPress websites that have no other caching plugin installed/enabled.

Developed by LiteSpeed Technologies, the LiteSpeed Cache plugins are designed to hyper-charge popular web apps with little to no configuration required. It can turbo-charge popular web apps with minimal fuss, handle traffic spikes with ease, and precisely manage cache with powerful Smart Purge technology.

LiteSpeed Cache was previously only available for Plus+ hosting plans, but due to the issues experienced lately, we have decided to make it available for all clients at no additional cost.

The LiteSpeed Cache plugin for WordPress will be automatically installed and enabled for all compatible WordPress installations on the server on Wednesday, the 14th of November 2018.

The LiteSpeed Cache plugin will not be installed on incompatible WordPress installations, flagged installations or installations that already have a caching plugin enabled.

What are the benefits of LiteSpeed Cache?

As the benchmark tests show, LSCache can improve performance by up to 120% when compared to other popular caching plugins. The performance gain is much higher if no caching system is used at all.

By implementing LSCache to as many websites as possible, not only would our server become faster and more stable, but also your websites would benefit by loading much faster.

What if I use a different caching plugin? (W3 Total Cache, WP Super Cache, WP Rocket, etc.)

If you use some other caching plugin, LSCache will not be installed automatically to avoid conflicts.

We highly recommend you replace any other caching plugin and give LSCache a try, as we’ve seen significant improvements on all websites that we’ve installed it on. The most significant results were seen on websites that used no caching plugin or any of the above-mentioned plugins.

If LSCache fails to be installed automatically, you can manually install it through WordPress or in cPanel under “LiteSpeed Web Cache Manager”.

What if my website is based on a different platform (e.g. Joomla, Drupal)?

LSCache is available for many platforms already, including Joomla, Magento, PrestaShop, OpenCart, Drupal 8, xenForo and MediaWiki. You can find all LSCache plugins here: https://www.litespeedtech.com/products/cache-plugins

Unfortunately, the LiteSpeed Web Cache Manager for cPanel, which automatically installs the WordPress plugin, is only available for WordPress currently. The LSCache for other platforms must be installed manually, which is very easy and requires minimal knowledge.

Does LiteSpeed Cache have any disadvantages or cause any issues?

None that we are aware of. So far, we and our clients had only positive experiences with LSCache.

Is there any step required from my side prior or after the installation of LSCache?

The installation will be handled automatically for all WordPress websites detected on the server. There’s no action required from your side, except if you don’t want the plugin installed (see below).

LSCache requires little to no configuration, but you can tweak its settings in WordPress, if necessary.

Please note that the LSCache plugin requires WordPress 4.0 or later. If you’re running an older WordPress version, we strongly advise you to upgrade immediately, especially for security reasons.

What if I don’t want to use LiteSpeed Cache?

If for any reason you don’t want our system to install the LSCache plugin on your website, you can simply place a “flag” that tells LiteSpeed not to install the plugin on your website.

The “flag” can be placed in cPanel under “LiteSpeed Web Cache Manager” or by adding an empty file called “.litespeed_flag” in the folder where WordPress is installed.

If LiteSpeed Cache will be already installed, you can either remove it through WordPress or disable it through “LiteSpeed Web Cache Manager” in cPanel.

Should you have any questions or concerns related to LSCache, please don’t hesitate to contact us.

Update on 14.11.2018: LiteSpeed Cache has been successfully installed/enabled for all compatible WordPress installations. If your WordPress installation was flagged, outdated or had a different caching plugin in use LSCache has not been installed for it. You can manually install it after upgrading WordPress and/or after disabling any existing caching plugin.

If your website runs a different platform than WordPress, LSCache has plugins for various different platforms available here: https://www.litespeedtech.com/products/cache-plugins

During the scan, 51 WordPress installations were found to be running versions lower than 4.0. Some were even running WordPress v2, which is over 13 years old!

It is quite worrying to see that there are still many WordPress sites that have not been updated since years or even over a decade. There are hundreds of known vulnerabilities affecting WordPress 2.0 to 4.9 that can be easily exploited by any remote attacker. In some cases, these attacks can affect not only the vulnerable website, but our entire server and all hosted websites. If you or your clients run WordPress and you haven't updated it and its themes/plugins, we strongly urge you to do this soonest possible. For your safety, for the safety of our servers and for the safety of all other clients. Leaving a WordPress installation unpatched for years is simply irresponsible.

This task is now completed. It should help the respective websites load faster now and hopefully it will also improve with the overall performance/stability of our server.

If you notice any issues that might be related to LSCache, please contact our technical support department. Thank you!

Update 17.11.18 15:33 CET: We have switched the system default version and all accounts to PHP 7.1, except the accounts that have PHP 7.2 already enabled.

If your website returns a 500 Internal Server Error, it is most definitely related to the PHP version 7.1 being incompatible with your scripts. The exact reason is usually logged in the "error_log" file under the folder where your script is located (e.g. the "public_html" folder). You should update your scripts to assure compatibility with PHP 7.1 or higher.

You can switch back to PHP 5.6 or 7.0 if you need, in cPanel under "Select PHP Version".

Please note that we provide limited support for accounts running PHP 7.0 or lower.

  Print


Comments


  Add Comment

Confirm Submission

Please enter the text from the image in the box provided, this helps us to prevent spam.



Powered by WHMCompleteSolution